PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : CSS-Dateien zusammenfassen und komprimieren klappt nicht.



Tiggr
13.12.2007, 17:05
Hallo,

wie oben schon beschrieben zerfetzt das Zusammenfassen der CSS Dateien mein Design. Ich habe schon zahlreiche Foren durchsucht und nicht hilfreiches gefunden... - Meine Drupal-Version ist die aktuelle 5.5 in welcher der benötigte Patch schon integriert wurde (habs nachgesehen). So wie ich das Ganze verstanden habe, soll der Patch die doppelten UTF-8 Anweisungen entfernen. Dies tut er aber anscheinend nicht wirklich...

Geändert habe ich die Dateien nicht, bis auf ein paar Farben und Hintergrundbilder. Normale Anpassungen also...

Über eine kurzfristige Hilfe würde ich mich sehr freuen! ;)

Achso, falls es wichtig ist. Die Drupal-Lizenz habe ich bestellt, der Bestellvorgang wurde nur noch nicht bearbeitet.

Den Code musste ich leider anhängen, da er die max. 20000 Zeichen überschritten hat.

LG der Tiggr!

hass
13.12.2007, 18:04
Hast Du "öffentliche Download-Methode"? Mit "Privat" geht das nicht... von Änderungen am CSS kann so etwas nicht passieren. Schätze Es wurde etwas an den PHP Dateien geändert. Schau mal in den PHP Logs was da für Fehler kommen... was hast Du an den PHP Dateien alles verändert?

Tiggr
13.12.2007, 18:56
Hallo,

die Einstellungen passen alle. Die Datei wird erstellt und ich kann Sie per Browser aufrufen, einige Teile werden vom Browser auch umgesetzt bis zu einem bestimmten Punkt. Dannach scheint die Verarbeitung abzubrechen... :-/

Die PHP Dateien habe ich geringfügig verändert, dies hat meiner Meinung nach aber nichts mit dem CSS zu tun. Alle Änderungen die ich gemacht habe, stammen aus diesem Tutorial: http://www.shellmultimedia.com/tutorials/user-profiles-version-2

Was evtl. noch wichtig sein könnte und in der TXT Datei nicht dargestellt wird, sind komische Zeichen vor dem UTF-8 String: @charset "UTF-8";

Liegt hier evtl. der Hund begraben?

LG

Tiggr
13.12.2007, 19:23
So, ich habs gefunden! Dieser Thread http://forum.yaml.de/index.php?topic=3961.0 hat mich auf die Lösung gebracht...

Irgendwas an den CSS Dateien war nicht richtig, mit einem normalen Editor leider nicht zu sehen... :-( Ich habe alle Dateien mit TextPad geöffnet und ohne Änderungen per "Speichern unter..." als UNIX UTF-8 erneut gespeichert. Hochgeladen, alle gecachten Datein gelöscht (zum xten mal *g) und siehe da, es geht! Die komischen Zeichen am Anfang der Dateien sind damit auch verschwunden.

Ich denke es lag am Dreamweaver, da er meines wissens ein Byte am Textanfang ersetzt oder zusätzlich speichert was viele PHP Anwendungen aus dem Takt bringen kann... - Lasse mich hier gerne korrigieren, aber nun gehts! *freu*

hass
13.12.2007, 21:07
http://www.yaml-fuer-drupal.de/de/einfuehrung/entwicklungsplatform. Das "komische Zeichen" ist eine "Byte Order Mark" und diese darf es in Drupal nicht geben... Notepad macht das auch. Ich glaube ich muss mal eine schwarze Liste der Editoren veröffentlichen. ;D

Schau mal ob du deinen Textpad dazu bringen kannst in UTF8 Dateien kein BOM's einzubauen. Dann sollte das auch mit Textpad funktionieren.

Tiggr
13.12.2007, 21:16
Hi, ne schwarze Liste wäre super! ;-)

Textpad machts ja richtig... Ich denke mal das Dreamweaver das Ganze verbockt hat, denn als ich den anderen Beitrag gefunden habe wurde mir einiges klar. Hatte den gleichen Stress schon einmal und mir den gleichen Wolf gesucht. Nur war es damals PHP mit nem Header-Redirect. Das CSS genauso ausrastet wusste ich nicht. :o

Lustigerweise stehe ich nun vor dem nächsten Problem, was allerdings nichts mit YAML zu tun haben sollte: Theme Settings API + Cache = weiße Seite mit Fehlermeldung. arg() fehlen Parameter... - Nach anfänglicher Begeisterung nervts langsam irgendwie. CSS Datein sind jetzt jedenfalls kompimiert, wenn auch ohne Cache. ???

hass
13.12.2007, 21:36
Versuch mal bitte ein Downgrade auf Theme setting API 2.5 und sag mir bitte bescheid, ob es dann weg ist... dann mach ich sofort den Downgrade im Komplettpaket. Habe von dem Problem auch gerade eben erst gelesen http://drupal.org/node/199635.

Ich kann das Problem nicht reproduzieren und auf YAML für Drupal ist 2.6 installiert und Caching selbstverständlich aktiviert. ???

Tiggr
13.12.2007, 22:28
Hallo,

ich habe gerade auf die 2.5er "downgegraded" und es klappt. Bei mir tritt das Problem auch nur im Zusammenhang mit dem Blogmodul auf, sprich auf Blogseiten. Normale Nodes machen keine Probleme... - Hoffe das hilft etwas bei der Suche.

Ansonsten saubere Arbeit! ;D Und vielen Dank für die schnelle Hilfe!

Einen schönen Abend noch!

hass
14.12.2007, 00:34
Sorry, aber derzeit sieht es eher danach aus, als wenn Du auf 2.3 zurück musst... bzw. 2.7. Einen Patch gibt es wohl schon...